If you think that something doesn't work in Aware IM post your message here
#45024 by karelh
Sat Sep 30, 2017 10:57 pm
Hi,

I came across a problem where negative numbers are not shown on the forms. They display correct under queries and grids but not on any form. When you open the form you can see the number for a split second but as soon as the form has it styles applied it disappears.(Just blank) If you change the number to a positive value then it displays correct. Has anyone else experienced this problem?
#45040 by BenHayat
Mon Oct 02, 2017 1:35 pm
karelh wrote:After some more testing I figured out it is only when using currency as the format. (I tried the default currency format and a custom one)


Please create a simple Test BSV with instruction to run it and send to Support.
#45045 by JonP
Tue Oct 03, 2017 3:16 am
In a possibly related issue, ranges won't take negative numbers.

1. Use/create a number attribute.
2. Try to set the "Min. Value" to a negative number. At first, the control will replace the "-" with a "0", but if you type "-" a second time, it will show up and you can replace the 0 with the desired value (the replaced "-" could be a clue that this is a known issue).
3. Enter your "Max. Value", save and close the BO.
4. Open the BO again and notice the range is gone.
#51538 by jannes
Sun Sep 08, 2019 11:50 am
Is this already solved?

I'm facing the same problem.

A negative value is visible in the grid, but not in the (regular) form.

Type : Number
Format : $###,##0.00
Min / max value : empty

When entering min/max value, it disappears after reopening the BO.

Locale : Dutch

How to show a negative value in a form using a currency symbol ?

= Jannes
#51541 by aware_support
Sun Sep 08, 2019 10:58 pm
Do not use the dollar sign as part of the format. Add it to the label instead or display it after the control. In queries use "Display format" to display it. The dollar sign in format could be the cause of the problem

Who is online

Users browsing this forum: No registered users and 14 guests