If you think that something doesn't work in Aware IM post your message here
#50762 by hpl123
Tue Apr 23, 2019 11:10 am
Hi support,
I have a peculiar problem I don´t understand and hoping for some enlightenment from you (or anyone else that knows the answer). I try to connect to an external database using a MySQL auto-incremented number field as primary key and I get the error message "Value for primary key meta_id is not defined." which isn´t correct (the meta_id is auto-incremented and all rows are populated).

Aware settings:
db1.PNG
db1.PNG (5.46 KiB) Viewed 2821 times


DB field settings:
db2.PNG
db2.PNG (9.66 KiB) Viewed 2821 times


Thanks in advance
#50763 by hpl123
Tue Apr 23, 2019 11:30 am
Update:
The problem seems to be that the field use the "unsigned" setting for the field, I removed it and then all works as it should. Is this a bug or can´t Aware handle unsigned? The problem is not just with the primary key thing, Aware can´t read unsigned fields at all (all unsigned fields are displayed as empty in Aware queries).

Thanks
#50939 by hpl123
Wed May 29, 2019 4:22 pm
Not sure what you are testing etc. but the bug is if the DB field has "unsigned" enabled for the primary key field/column. If it has, Aware does not display the value in the primary key field in Aware queries etc. and it also not possible to change stuff. In your tests, do you see the value of the primary key field in Aware? Can you change stuff? Is the field set with unsigned enabled in the DB?
#50942 by aware_support
Wed May 29, 2019 11:56 pm
I have created an integer column in MySQL with the UNSIGNED attribute. When discovering attributes for the table I have specified this column to be the primary key. Then I have defined a query that shows values of this table and the Edit operation with records.

The query works fine and I can also edit and change records (not the primary key, though)
#50951 by hpl123
Thu May 30, 2019 2:30 pm
aware_support wrote:I have created an integer column in MySQL with the UNSIGNED attribute. When discovering attributes for the table I have specified this column to be the primary key. Then I have defined a query that shows values of this table and the Edit operation with records.

The query works fine and I can also edit and change records (not the primary key, though)


Strange, sounds right and same as my setup and does not work for me. I am on v8.2 b2565.

Who is online

Users browsing this forum: No registered users and 7 guests