If you have questions or if you want to share your opinion about Aware IM post your message on this forum
#50694 by rocketman
Wed Apr 10, 2019 11:09 pm
Has anyone got Paypal working with an SSLforFree certificate? I am unable to receive the callback. Everything worked fine until I installed a certificate. No code has changed. This was following a call to PayPal but the user cancelled the transaction
****************
Type Status Report

Message /AwareIM/req.awurl&BAS_SUCCESS=false

Description The origin server did not find a current representation for the target resource or is not willing to disclose that one exists.
#50728 by rocketman
Sun Apr 14, 2019 11:56 am
OK so this is hurting now.

I have eliminated the possibility of this being an SSL issue by. configuring a test machine and registering a spare domain name that now point to it. I have opened up port 8080 on my router/firewall and I port forward 8080 to the test machine on the network There is NO SSL certificate installed and 8080 is the only port open on the home router.

I still get the same error message as in the original post and the url that is coming back from PayPal is

http://mydomain.org.uk:8080/AwareIM/req ... CESS=false

This seems to get truncated. the last bit is req.awurl&BAS_SUCCESS=false

Could it be that I have my external firewall locked down too tight and I actually need some other ports open to receive PayPal callbacks?. This is the standard vanilla out of box Paypal integration - nothing fancy.

Any help appreciated.
Last edited by rocketman on Mon Apr 15, 2019 12:12 am, edited 1 time in total.
#50730 by rocketman
Sun Apr 14, 2019 11:43 pm
so the returning url from PayPal is http://mydomain.org.uk:8080/AwareIM/req ... CESS=false truncated again - the last bit is req.awurl&BAS_SUCCESS=false

Maybe something is hidden but I would have thought that req.url would have been replaced with something OR in the name/value pair convention, the string should read ....req.url?BAS_SUCCESS=false since & is usually used for second and subsequent name/value pairs

If it IS req.awurl I cant find a webpage with that name in the tomcat folder
Last edited by rocketman on Mon Apr 15, 2019 12:13 am, edited 1 time in total.
#50731 by rocketman
Mon Apr 15, 2019 12:04 am
OK so when I got the return call from Paypal I changed the & for a ? in the url string and managed to get the passback to my app with the correct "Process Failed" message.

So Support, could you please provide a fix for this in my version of AIM or tell me which file I need to edit to put this right

Image

Who is online

Users browsing this forum: Google [Bot] and 24 guests