IMPORT using "*" instead of ID not working anymore

If you think that something doesn't work in Aware IM post your message here
Post Reply
ACDC
Posts: 990
Joined: Sat Jun 30, 2007 5:03 pm

IMPORT using "*" instead of ID not working anymore

Post by ACDC »

Being able to import a .csv file using its own key has always been possible by indicating the key with a "*" It seems this feature has gone away

This feature is no longer working, I spent a full day chasing down the problem thinking that it was the formatting of my CSV file after reading about how incorrectly formatted .csv file can lead to import failures - not all .csv files are equall :shock:

I mean I have done this many times in V7.1, so let me try V7.1 and see if it fails as well ...and voila the same file works the first time around

From this log report you can see the IMPORT function cannot find the ID, shouldn't it be looking for the ProductCode ?

Please could we revive this feature or sort the bug out, it's a vital piece needed when transitioning from other systems

here's some of the content of my csv :

Code: Select all

*Product.ProductCode,Product.OpeningBal1,Product.OpeningBal2
6912K00050,10.00,1
104RT1121,40.00,4
059PP590951,10.00,1  
Here's the Process to IMPORT

Code: Select all

IMPORT Product FROM 'c:/ProductListImport/productlist.csv'
This is the failure error in log
Attachments
Import ID wrong.jpg
Import ID wrong.jpg (207.42 KiB) Viewed 377 times
Jaymer
Posts: 1889
Joined: Tue Jan 13, 2015 10:58 am
Location: Tampa, FL
Contact:

works up thru 8.2

Post by Jaymer »

At one site, i'm on 8.2 and this has worked since v7
no issues
imports daily via process

Code: Select all

IMPORT O FROM 'c:\Imports\ImpOrders.FIXED.txt' CREATE IF NOT FOUND 
CREATE CincyImportResults WITH 
	CincyImportResults.ErrorsDetected=ImportResults.ErrorsDetected,
	CincyImportResults.Log=ImportResults.Log,
	CincyImportResults.ImpTimestamp=CURRENT_TIMESTAMP,
	CincyImportResults.Type='O' 

Code: Select all

*O.Order_Num,"O.Date_Ordered","O.Status","O.Date_Status","O.ob_Customer.ID","O.JobName","O.ControlNum","O.EmailNum","O.CustOrderNum","O.Amt_Order","O.XrefOrder","O.ServiceYN","O.KeyedBy","O.CommentsYN",O.OrderPlus -1408
795751,"06/30/2020","I","12/12/2020",Mast_Cust#200100,"TURNER"," 0"," 0","TO795751"," 0.00","793116","Y","","",795751.793116
805165,"09/04/2020","I","01/20/2021",Mast_Cust#200026,"MUNRO 9717"," 4941","294294","CL805165"," 235.32","775034","Y","","",805165.775034

Code: Select all

*L.PriKey,L.ob_Order.Order_Num,L.Order_Num,L.Line,L.Status,L.Qty,L.UM,L.Product,L.QCode,L.ps_Product.ID,L.Inventory_Id,L.Description,L.Factory_Line,L.Cust_ID,L.Cost_Line_Item,L.Cost_Ext,L.CommentsYN,L.Dimensions,L.Dim_Width,L.Dim_W_Fract,L.Dim_Height,L.Dim_H_Fract,L.Dim_W_Points,L.Dim_H_Points,L.Option_1,L.Option_2,L.Option_3,L.Option_4,L.Option_5,L.Option_6,L.Option_7,L.Option_8,L.Option_9,L.Correlated_Order,L.Correlated_Line,L.MU_Num_Children,L.MU_Parent_Line,L.MU_Group,L.Feat1_Abrv,L.Feat2_Abrv,L.Feat3_Abrv,L.Feat4_Abrv,L.Feat5_Abrv,L.Feat6_Abrv,L.Feat7_Abrv,L.Feat8_Abrv,L.Feat9_Abrv,L.Category1,L.Category2,L.Category3,L.Category4,L.Category5,L.Category6,L.Category7,L.Category8,L.Category9,L.Section1,L.Section2,L.Section3,L.Section4,L.Section5,L.Section6,L.Section7,L.Section8,L.Section9,L.FtrTable1,L.FtrTable2,L.FtrTable3,L.FtrTable4,L.FtrTable5,L.FtrTable6,L.FtrTable7,L.FtrTable8,L.FtrTable9,L.Repair_Remake,L.Oriel_Offset,L.OrielYN,L.Extreme_SizeYN,L.OO_YN,L.OO_ProductYN,L.OO_DenverYN,L.Date_Completed,L.Date_Data_Entry,L.Data_Entry_ID,L.Install_Loc1,L.Install_Loc2,L.Breakdown,L.Template,L.ps_Template.ID,L.Pos2,L.Pos3,L.Pos4,L.Pos5,L.Pos6,L.Pos7,L.Pos8,L.Pos9 -1408
79575101,795751,795751,01,F, 1,EA,GWS2,GWIGTRAP,Mast_Product#5337,,"GARDEN WINDOW IG TRAP",23,T00001,,,N,13 x 29 1/2, 13,, 29,1/2, 0, 8,RV,,,,,,,,,793116,01,,,,RGT VENT,,,,,,,,,Venting,,,,,,,,,,,,,,,,,,007,000,000,000,000,000,000,000,000,Y, 0.000000,,N,N,,,12/12/2020,06/30/2020,VKOSTER,"","",,,Mast_Template#0000,,,,,,,,
80516501,805165,805165,01,F, 1,EA,GS11,IGTEMP,Mast_Product#5393,,"INSULATED GLASS UNIT TEMPERED",10,A00010, 235.32, 235.32,N,31 3/4 x 73 1/4, 31,3/4, 73,1/4,12, 4,WH,TL,NG,,,,,,,,,,,,WHITE,TEMPLOWE,NO GRIDS,,,,,,,PD COLOR,TEMP,Grids,,,,,,,,G1-GLAS-FL,GR-GRDD,,,,,,,061,051,003,000,000,000,000,000,000,, 0.000000,,N,Y,,,01/20/2021,09/04/2020,VKOSTER,"","",,,Mast_Template#0000,,,,,,,,
81228001,812280,812280,01,F, 1,000,8202,822P,Mast_Product#4510,,"8200 2-PANEL",82,A00013, 331.30, 331.30,N,71 1/4 x 59, 71,1/4, 59,, 4, 0,WH,DE,NG,DE,NG,HS,HD,,,,,,,,WHITE,DS LEA,NO GRIDS,DS LEA,NO GRIDS,HALF SCR,HDRAIL,,,Color,Glass,Grids,Glass,Grids,Screens,SCRNSTYL,,,,G7-GLAS-LT,GR-GRID-LT,G7-GLAS-RT,GR-GRID-RT,SC-SCRN-RT,,,,073,002,003,002,003,004,099,,,, 0.000000,,N,N,,,11/09/2020,00/00/0000,,"","",,,Mast_Template#0000,LEFT,LEFT,RIGHT,RIGHT,,,,
81228002,812280,812280,02,F, 1,000,8202,822P,Mast_Product#4510,,"8200 2-PANEL",82,A00013, 235.00, 235.00,N,47 1/4 x 47, 47,1/4, 47,, 4, 0,WH,LE,NG,LE,NG,HS,HD,,,,,,,,WHITE,LE ARGON,NO GRIDS,LE ARGON,NO GRIDS,HALF SCR,HDRAIL,,,Color,Glass,Grids,Glass,Grids,Screens,SCRNSTYL,,,,G7-GLAS-LT,GR-GRID-LT,G7-GLAS-RT,GR-GRID-RT,SC-SCRN-RT,,,,073,002,003,002,003,004,099,,,, 0.000000,,N,N,,,11/09/2020,00/00/0000,,"","",,,Mast_Template#0000,LEFT,LEFT,RIGHT,RIGHT,,,,
Click Here to see a collection of my tips & hacks on this forum? Or search for "JaymerTip" in the search bar at the top.

Jaymer
Aware Programming & Consulting - Tampa FL
ACDC
Posts: 990
Joined: Sat Jun 30, 2007 5:03 pm

Re: IMPORT using "*" instead of ID not working anymore

Post by ACDC »

At one site, I'm on 8.2 and this has worked since v7
Is it possible for you to try it on 8.5 ?, I am convinced its a bug
Jaymer
Posts: 1889
Joined: Tue Jan 13, 2015 10:58 am
Location: Tampa, FL
Contact:

Re: IMPORT using "*" instead of ID not working anymore

Post by Jaymer »

on 8.5, i have other imports, but not that style.
and i can't update that site to 8.5 yet, so can't really help on that right now.
Click Here to see a collection of my tips & hacks on this forum? Or search for "JaymerTip" in the search bar at the top.

Jaymer
Aware Programming & Consulting - Tampa FL
BobK
Posts: 464
Joined: Thu Jan 31, 2008 2:14 pm
Location: Cincinnati, Ohio, USA

Re: IMPORT using "*" instead of ID not working anymore

Post by BobK »

Using the latest build (Version 8.5 Build 2835) and it worked for me.

Contents of csv:
*BTimeStamp.vin,BTimeStamp.eventType
3VWNJ81K86M6788101,new
3VWNJ81K86M67881022,new
3VWNJ81K86M6788105,new
Rule:

Code: Select all

IMPORT BTimeStamp FROM 'C:/Bob/testImport.csv'
Contents of main.log:
2021-03-04 15:38:11,047 ALL_NO_TIMER Test#admin -Starting external request executeProcess
2021-03-04 15:38:11,047 RULE_EVALUATION Test#admin -17
2021-03-04 15:38:11,047 RULE_EVALUATION Test#admin -17
2021-03-04 15:38:11,047 RULE_EVALUATION Test#admin -20 Executing process ImportProcess
2021-03-04 15:38:11,047 RULE_EVALUATION Test#admin -29 Started evaluation of rules
2021-03-04 15:38:11,047 RULE_EVALUATION Test#admin -22 Evaluating rule 'JustDoIt' IMPORT BTimeStamp FROM 'C:/Bob/testImport.csv'
2021-03-04 15:38:11,047 RULE_EVALUATION Test#admin -2 Adding action IMPORT BTimeStamp FROM 'C:/Bob/testImport.csv' to the agenda
2021-03-04 15:38:11,047 RULE_EVALUATION Test#admin -16 Finished rule evaluation
2021-03-04 15:38:11,047 RULE_EVALUATION Test#admin -16 Finished evaluation of rules
2021-03-04 15:38:11,047 RULE_EVALUATION Test#admin -15 Executing action IMPORT BTimeStamp FROM 'C:/Bob/testImport.csv'
2021-03-04 15:38:11,475 RULE_EVALUATION Test#admin -Importing business object BTimeStamp
2021-03-04 15:38:11,489 RULE_EVALUATION Test#admin -36 Data import has been completed. 3 records have been processed
2021-03-04 15:38:11,499 RULE_EVALUATION Test#admin -16 Finished executing action IMPORT BTimeStamp FROM 'C:/Bob/testImport.csv'
2021-03-04 15:38:11,499 RULE_EVALUATION Test#admin -25 Started evaluation of rules after data has been changed by the actions
2021-03-04 15:38:11,499 RULE_EVALUATION Test#admin -6 Checking rule JustDoIt
2021-03-04 15:38:11,499 RULE_EVALUATION Test#admin -16 Finished evaluation of rules after data has been changed by the actions
2021-03-04 15:38:11,499 RULE_EVALUATION Test#admin -16 Finished executing process ImportProcess
2021-03-04 15:38:11,499 RULE_EVALUATION Test#admin -17
2021-03-04 15:38:11,499 RULE_EVALUATION Test#admin -17
Bob
PointsWell
Posts: 1067
Joined: Tue Jan 24, 2017 5:51 am
Location: 'Stralya

Re: IMPORT using "*" instead of ID not working anymore

Post by PointsWell »

Intrigued by this - is the * for ID documented somewhere? I couldn't find it but have a problem that might be fixed by it
ACDC
Posts: 990
Joined: Sat Jun 30, 2007 5:03 pm

Re: IMPORT using "*" instead of ID not working anymore

Post by ACDC »

Intrigued by this - is the * for ID documented somewhere? I couldn't find it but have a problem that might be fixed by it
Pg 100 of the user guide
Attachments
ImportStar.jpg
ImportStar.jpg (57.86 KiB) Viewed 304 times
PointsWell
Posts: 1067
Joined: Tue Jan 24, 2017 5:51 am
Location: 'Stralya

Re: IMPORT using "*" instead of ID not working anymore

Post by PointsWell »

ACDC wrote: Tue Mar 09, 2021 8:33 pm
Intrigued by this - is the * for ID documented somewhere? I couldn't find it but have a problem that might be fixed by it
Pg 100 of the user guide
Thank you!
Post Reply